SQLiteInit

SQLiteInit

Используется для инициализации SQLite движка. Команда должна быть вызвана при старте программы, перед всеми другими командами плагина. Возвращает "1" при успешном старте движка (переменная IsInitialized в примере).

Пример:

Перевод © 2008 [mbf-4]DEMBEL


CreateSQLDB

CreateSQLDB

Используйте команду для создания файла БД на вашем жестком диске. Эта команда требует имя файла БД (например: mydata.db) и путь. Возвращает "1" при успехе и другие значения при неудаче.

Пример:


GetDBFileName

GetDBFileName

Используется совместно с командой CreateSQLDB. Должна быть вызвана до команды CreateSQLDB для передачи имени файла БД в плагин.

Пример:


OpenSQLDB

OpenSQLDB

Используется для открытия ранее созданной БД с целью взаимодействия с ней и передачи SQL запросов. Возвращает "1" при успехе.

Пример:


Query

Query

Это основная команда плагина. Используется для отправления SQL запросов к SQLite. Может использоваться для всех видов запросов, совместимых с SQLite. Возвращает результат запроса или набор результатов в строковой переменной с разделителями. На функции совокупности (aggregate functions) возвращает результат в строковую переменную без разделителей.
SQLite плагин может возвращать смешанные результаты (пример для 2 строк данных):

1|name1|password1||2|name2|password2||

В конце каждой строки - двойная вертикальная линия. Также команда возвращает одно целочисленное значение для обозначения числа строк в наборе результатов.

Пример:


UpdateDB

UpdateDB

Выполняет SQL запросы к БД. Эта функция похожа на Query, но используется специфически для SQL запросов, которые не имеют результата, типа 'Update' (обновить) или 'Create' (создать). Однако запросы типа 'SELECT' (выбрать) с помощью этой команды выполнить нельзя. Эта функция полезна для обновления записей в БД. Если возвращаемый результат "0", тогда запрос был неверно обработан (из-за ошибки SQL или неверного формата запроса). Текст ошибки может быть возвращен используя DBError.

Пример:


DBFileSize

DBFileSize

Возвращает размер файла ДБ в байтах. /* Комментарий в коде: заметьте, что файл ДБ внутренний. Все изменения, вносимые во время выполнения программы имеют временный характер. Если вам требуется необратимое обновление, сделайте файл БД внешним. */

Пример:


DBError

DBError

Возвращение последней ошибки ДБ в текстовом формате.


IsDB

IsDB

Эта функция проверяет, является ли заданная ДБ валидной и корректно инициализированной. При отрицательном результате возвращает "0". Должна запускаться после OpenSQLDB.


SetRecordDelimiter

SetRecordDelimiter

Позволяет задать знак разделителя (используется для разделения записей данных при возвращении набора результатов в одну строковую переменную, обычно используются знаки * # | или другие.


SetFieldDelimiter

SetFieldDelimiter

Позволяет задать знак разделителя (используется для разделения полей записей данных при возвращении набора результатов в одну строковую переменную, обычно используются знаки * # | или другие.


CloseDB

CloseDB

Команда закрытия ДБ. База также закрывается автоматически при выходе.


Encode64Data

Encode64Data

Кодирует строку используя алгоритм Base64. Часто используется для двоичных файлов, картинок. Результат содержит длину закодированной строки в байтах. Можно использовать для простой защиты данных. Возвращает "0" при неудачной обработке.


Decode64Data

Decode64Data

Декодирует строку, закодированную с помощью алгоритма Base64. Возвращает "0" при неудаче.


MD5Data

MD5Data

Возвращает 32-значный MD5 (Message Digest 5) хеш. Используется для разных данных, в т.ч. регистрозависимых, таких как пароли.

Пример:


SH1Data

SH1Data

Возвращает 40-значный SHA1 (Secure Hash Algorithm 1) хеш указанной строки, механизм аналогичен MD5Data, но использует другой алгоритм.


Плагин SQLite

Что такое SQLite?

SQLite это библиотека приложения, которая предоставляет самодостаточный, не требующий сервера движок транзакций SQL базы данных.. SQLite самый широкораспространенный движок SQL баз данных в мире. Используется в огромном количестве приложений, электронных устройств (сотовые, PDA, MP3 плееры). Исходники SQLite общедоступны.

Теперь с помощью SQLite плагина у вас в руках есть вся мощь SQLite для приложений MMB.